summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorFan Zhang <roy.fan.zhang@intel.com>2019-03-25 13:58:35 +0000
committerAkhil Goyal <akhil.goyal@nxp.com>2019-04-02 16:50:24 +0200
commit7b2d4706c90ef756a4b7ec3395bb7c81ffbcdbf4 (patch)
treef17e2839152c4e1ada8211ff183a4138da6acb99 /doc
parent5e73a1f8156c73484ab9c8a59e5b35d0c75aae7c (diff)
downloaddpdk-draft-windows-7b2d4706c90ef756a4b7ec3395bb7c81ffbcdbf4.zip
dpdk-draft-windows-7b2d4706c90ef756a4b7ec3395bb7c81ffbcdbf4.tar.gz
dpdk-draft-windows-7b2d4706c90ef756a4b7ec3395bb7c81ffbcdbf4.tar.xz
crypto/aesni_mb: support newer library version only
As stated in 19.02 deprecation notice, this patch updates the aesni_mb PMD to remove the support of older Intel-ipsec-mb library version earlier than 0.52. Signed-off-by: Fan Zhang <roy.fan.zhang@intel.com> Acked-by: Pablo de Lara <pablo.de.lara.guarch@intel.com>
Diffstat (limited to 'doc')
-rw-r--r--doc/guides/cryptodevs/aesni_mb.rst7
-rw-r--r--doc/guides/rel_notes/deprecation.rst3
2 files changed, 2 insertions, 8 deletions
diff --git a/doc/guides/cryptodevs/aesni_mb.rst b/doc/guides/cryptodevs/aesni_mb.rst
index 55aa7cd..8915201 100644
--- a/doc/guides/cryptodevs/aesni_mb.rst
+++ b/doc/guides/cryptodevs/aesni_mb.rst
@@ -56,10 +56,6 @@ Limitations
-----------
* Chained mbufs are not supported.
-* RTE_CRYPTO_AEAD_AES_GCM only works properly when the multi-buffer library is
- 0.51.0 or newer.
-* RTE_CRYPTO_HASH_AES_GMAC is supported by library version v0.51 or later.
-* RTE_CRYPTO_HASH_SHA* is supported by library version v0.52 or later.
Installation
@@ -91,7 +87,8 @@ and the Multi-Buffer library version supported by them:
17.05 - 17.08 0.45 - 0.48
17.11 0.47 - 0.48
18.02 0.48
- 18.05+ 0.49+
+ 18.05 - 19.02 0.49 - 0.52
+ 19.05+ 0.52+
============== ============================
diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst
index 7646579..d5a79a3 100644
--- a/doc/guides/rel_notes/deprecation.rst
+++ b/doc/guides/rel_notes/deprecation.rst
@@ -70,9 +70,6 @@ Deprecation Notices
to consolidate color definition, which is currently replicated in many places,
such as: rte_meter.h, rte_mtr.h, rte_tm.h.
-* crypto/aesni_mb: the minimum supported intel-ipsec-mb library version will be
- changed from 0.49.0 to 0.52.0.
-
* cryptodev: New member in ``rte_cryptodev_config`` to allow applications to
disable features supported by the crypto device. Only the following features
would be allowed to be disabled this way,